26

Re: Агат-9 - проблемы с прохождением теста Лисина

slammy пишет:

На ШД наблюдаю вот такое, на всех разрядах

Это нормально для девятки - разработчики не поставили резисторы подтяжки и в моменты, когда через шину ничего не пересылается, она медленно подтягивается к "1" токами утечки.

slammy пишет:

На в.9 D4 тоже какая-то ерунда, вылезают 3 импульса подряд:

Три записи подряд - это может быть команда BRK, она пишет регистр флагов и два байта адреса. Или вызов обработчика прерывания.

slammy пишет:

И странные тайминги, по идее процессор должен общаться к ШД 50% времени, а 50% - ВК

D4 используется при обращении к памяти и устройствам ввода-вывода. Если процессор выполняет код из ПЗУ монитора, D4 отключена.

slammy пишет:

На в.7 D20 вижу вот такое:

Это нормально, я на всех платах такое видел. Там не просто так сигнал на D9 заводится, явно для очистки от этих "просечек".

27 Отредактировано slammy (11-12-2020 22:50)

Re: Агат-9 - проблемы с прохождением теста Лисина

Понятно, спасибо за консультации по схеме, видимо, дело действительно не в этом узле. Не знаю даже теперь, куда копать, были подозрения на разрушение данных в ОЗУ, судя по картинке, но видимо дело не в этом.
https://i.ibb.co/zZG2TVv/IMG-7452.jpg
---
Решил для пробы поменять ранее замененную мс ОЗУ на другую и о чудо, глюк ушел (вроде бы). Не знаю правда, как дефектная микросхема могла вызывать подобное разрушение данных.
Надеюсь теперь последний вопрос к знатокам, от чего может дублироваться первый пиксель в строке на месте последнего (обвел красным на фото)?
https://i.ibb.co/VvvpMft/IMG-7451.jpg

28

Re: Агат-9 - проблемы с прохождением теста Лисина

Дефектное ОЗУ легко может вызвать такое разрушение. Например, если внутренний дешифратор микросхемы ОЗУ неисправен, то запись в одни адреса приведет к изменению битов в совсем других адресах. В том числе в тех, где в данный момент находится исполняемый код самого теста ОЗУ.
Тест, конечно, содержит проверку целостности, но она выполняется только в определенные моменты. А если код начал меняться прямо в процессе теста, то тест это не заметит и результат будет непредсказуемым.

Насчет дублирующегося пикселя. Эта полоска по ширине заметно меньше целого пикселя режима Т32. Мне кажется, она даже меньше пикселя режима Т64. Размер пикселя в режиме Т64 определяется тактовой частотой ДК (10,5 МГц). Если бы что-то в схеме работало не так, то полоса была бы шире.
Мне кажется, это скорее дефект телевизора/монитора.

29

Re: Агат-9 - проблемы с прохождением теста Лисина

Да, думаю, в очередной раз ремонт можно считать завершенным, буду упаковывать в корпус. Спасибо всем за участие!

30

Re: Агат-9 - проблемы с прохождением теста Лисина

Собрал Агат в корпус, поменял кондеры в мониторе, такой вот получился красавец
https://i.ibb.co/FbPs3XH/IMG-7490.jpg
Но неожиданно перестал грузиться, на экране шахматка. При удалении платы контроллера принтера - заработал. "На вскидку" поменял ВА86, пробовал ставить в другие слоты, доставать остальные платы - не помогло. Из интереса поставил в Агат-7 и он заработал, по крайней мере не зависает и содержимое ПЗУ читается. Потыкал осциллографом - никаких обращений, кроме как к ПЗУ и ВА86 нет, ничего вроде на шину не гадит. При блокировке ВА86 подачей 1 на в.9 грузится без проблем, значит коротышей в разъеме нет. В чем может быть отличие архитектур агатов, обеспечивающую работу "нерабочей" платы расширения?

31

Re: Агат-9 - проблемы с прохождением теста Лисина

Шикарно выглядит!

С контроллером принтера что-то странное, я с таким не сталкивался. Могу только предположить, что девяточный ИКП неисправную плату принимает за модуль ДопОЗУ, пытается его проинициализировать и на этом ломается.

32 Отредактировано garnizon (04-01-2021 14:36)

Re: Агат-9 - проблемы с прохождением теста Лисина

А нельзя мне для сайта попросить сделать несколько фото монитора с загруженным ИКП (как на вашем фото) .
Чуть с разных ракурсов можно? вот для этой странички:
http://agatcomp.ru/agat/Hardware/Monic/VTC32.shtml

А то сейчас только трубка а самого моника не видно, а тут красненький :)

33

Re: Агат-9 - проблемы с прохождением теста Лисина

avivanov76 пишет:

Шикарно выглядит!

С контроллером принтера что-то странное, я с таким не сталкивался. Могу только предположить, что девяточный ИКП неисправную плату принимает за модуль ДопОЗУ, пытается его проинициализировать и на этом ломается.

Оказалась битой ИП7, выдавала лог.1 около 2,8 вольт, возможно еще и подсаживала шину, видимо для пустой семерки без плат расширения этого хватало, но девятку "клало на лопатки", после замены все работает отлично.


garnizon пишет:

А нельзя мне для сайта попросить сделать несколько фото монитора с загруженным ИКП (как на вашем фото) .
Чуть с разных ракурсов можно? вот для этой странички:
http://agatcomp.ru/agat/Hardware/Monic/VTC32.shtml

А то сейчас только трубка а самого моника не видно, а тут красненький :)

Хорошо, на неделе сделаю, надо монитор с рем. базы на квартиру притащить.
Кстати, общался с продавцом этого Агата https://www.avito.ru/moskva/tovary_dlya … 2079731483, заинтересовала клавиатура с белыми клавишами. Тот компьютер внутризаводской, подарен сотруднику ЛЭМЗа, а купили его в музей https://retro-computer.ru, там еще и дискеты с какой-то документацией в комплекте были.

34

Re: Агат-9 - проблемы с прохождением теста Лисина

slammy пишет:

Кстати, общался с продавцом этого Агата

Я этот агат даже оплатил с доставкой, но как оказалось поздно.

35

Re: Агат-9 - проблемы с прохождением теста Лисина

На всяк случай про ИКП и принтерный порт девятки: у ИКП есть ошибка в процедуре поиска устройств: если ячейки принтерного порта нет, то, в зависимости от начального состояние памяти, ИКП может зависнуть.

В коде процедуры применяется операция BIT в качестве маскировки следующей операции,
но программер, который это писал, забыл что BIT влияет на флаг V. А он в этой процедуре используется как локальная переменная. В итоге V портиться и цикл зависает.

Если ячейка принтера установлена, то как-то этот баг маскируется и не может проявиться.

К сожалению, не нашел описания подробностей, пишу по памяти.

36

Re: Агат-9 - проблемы с прохождением теста Лисина

Voldemar0 пишет:

На всяк случай про ИКП и принтерный порт девятки: у ИКП есть ошибка в процедуре поиска устройств: если ячейки принтерного порта нет, то, в зависимости от начального состояние памяти, ИКП может зависнуть.

В коде процедуры применяется операция BIT в качестве маскировки следующей операции,
но программер, который это писал, забыл что BIT влияет на флаг V. А он в этой процедуре используется как локальная переменная. В итоге V портиться и цикл зависает.

Если ячейка принтера установлена, то как-то этот баг маскируется и не может проявиться.

К сожалению, не нашел описания подробностей, пишу по памяти.

Интересное наблюдение, у меня конечно зависал ИКП, но это было еще в процессе наладки, так что даже не знаю, посетил меня сей баг или нет.

Пока остался один глюк - сбой по синхронизации (подергивание изображения) в режиме Apple, как в текстовом, так и в графическом. И это даже на аутентичном мониторе с аутентичным сведением цветов.
Вот видео: https://youtu.be/Y6967qCyC6o

37 Отредактировано garnizon (07-01-2021 01:18)

Re: Агат-9 - проблемы с прохождением теста Лисина

Спасибо, фото получил.

Занятно что зеленые буквы на красном фоне выглядят как оранжевые. Вижу такое не первый раз.
Интересно, это усталость моника или что-то еще?

http://agatcomp.ru/agat/Hardware/Monic/VTC32/201.jpg

Post's attachments

emul.png, 11.97 kb, 512 x 512
emul.png 11.97 kb, 2 downloads since 2021-01-06 

38

Re: Агат-9 - проблемы с прохождением теста Лисина

slammy пишет:

Пока остался один глюк - сбой по синхронизации (подергивание изображения) в режиме Apple, как в текстовом, так и в графическом. И это даже на аутентичном мониторе с аутентичным сведением цветов.

Вообще, за строчную синхронизацию отвечают D61 и D67. Но, если бы прошивка слетела, то эффект был бы виден в каждой строчке. Тут же "мусор" появляется случайно. Выглядит так, что в какие-то моменты дисплейный контроллер читает не из того адреса.

Основных причин две: либо где-то выход висит в "промежуточном" уровне, либо верхний ключ у выхода дохнет и фронты получаются сильно затянутыми.

Для начала надо проверить, что сигнал ПА стабильно стоит в нуле в режиме Apple, с 6 ноги D13 и с 7 ноги D81 нормальные импульсы приходят (что там ничего не дрыгается одновременно с глюками на экране). Проверить выходы D60. Потом хорошо бы сравнить, что там на входах и выходах D87 и D88.

Можно попробовать вот этот тест http://forum.agatcomp.ru//viewtopic.php?pid=2404#p2404. Если "мусор" будет окрашен в один цвет, можно будет прикинуть, какой разряд адреса глючит.

39

Re: Агат-9 - проблемы с прохождением теста Лисина

garnizon пишет:

Занятно что зеленые буквы на красном фоне выглядят как оранжевые. Вижу такое не первый раз.
Интересно, это усталость моника или что-то еще?

Тут немножко баланс белого в желтизну ушел. У меня на телике так выглядит:

Post's attachments

IMG_155924.jpg, 113.22 kb, 800 x 600
IMG_155924.jpg 113.22 kb, 3 downloads since 2021-01-06 

40

Re: Агат-9 - проблемы с прохождением теста Лисина

Цвета могут искажаться и фотоаппаратом. Красный на буквах внизу совсем не такой, как в центре экрана. Но в реале у нас так не было.

А подёргивание, случайно, не с моником самим связано ? Там может какие кондёры посохли.

41

Re: Агат-9 - проблемы с прохождением теста Лисина

slammy пишет:

Пока остался один глюк - сбой по синхронизации (подергивание изображения) в режиме Apple, как в текстовом, так и в графическом.

Я тоже сталкивался с подёргиваниями в Яблочном режиме.
В Яблочном режиме дисплейный контроллер тактируется от 7МГц и 1МГц через D81. Проверь стабильность и джиттер этих сигналов, особенно Ф0 (лучше всего, конечно, на запоминающем цифровом ослике).

Турбо АГАТ-9/16 (ЦП 65C802, 5 Махов, dual-port SRAM).

42

Re: Агат-9 - проблемы с прохождением теста Лисина

По поводу надписей оранжевого цвета, на мониторе проблемы со сведением лучей, красный цвет ближе к краю косит:
https://i.ibb.co/d55NzX7/IMG-7548.jpg
https://i.ibb.co/5vdhx1r/IMG-7549.jpg
Если честно мне не особо охото его копать, хотя электролиты я уже заменил, но в наличии есть мс6106, там трубка на порядок лучше по качеству изображения.

По поводу подергиваний в режиме Apple, такие глюки и на мониторе, и на телевизоре, так что что-то не то в самом Агате. Попробую запустить тест видео, а так действительно очень похоже на нестабильность частоты 10,5 МГц, в режиме Агата глюков нет. Снял несколько скриншотов из ранее снятого видео https://youtu.be/Pk_BOXq7KiY, правда в режиме ЧБ:
https://i.ibb.co/SRMKGLD/2021-01-07-14-43-47.png
https://i.ibb.co/GVxW1L1/2021-01-07-14-46-03.png
Видно, что строка сначала сканируется нормально, а затем выпадает, но надо конечно в цвете смотреть и на ЭЛТ мониторе, чем я и займусь в ближайшее время.

43

Re: Агат-9 - проблемы с прохождением теста Лисина

Наконец-то я победил дерготню изображения в режиме Apple, повесив конденсатор на 100 пФ между в.5 D81 (сигнал 7 МГц) и землей. Изначально при замере сигналов обнаружил, что при приложении щупа осциллографа к этому контакту глюки исчезают. Не знаю насколько "грязный" этот хак, и сильно ли это влияет на режим работы D9 (в моей версии платы сигнал подключен напрямую к в.3 без каких-либо буферных микросхем, возможно, их применили не зря), но вроде бы все функционирует нормально.

44

Re: Агат-9 - проблемы с прохождением теста Лисина

Поскольку ток перезарядки конденсатора ничем не ограничен, то D9 конечно "напрягается" несколько больше, чем обычно.
К тому же, такой хак не годится для серийного производства, потому что задержка зависит от конкретного экземпляра микросхемы.

С другой стороны, хаку сто лет и от его использования вроде никто не пострадал.

45

Re: Агат-9 - проблемы с прохождением теста Лисина

Да, было бы интересно проверить с буферным элементом на ТЛ2, как изображено в другой вариации схемы, но как говорится: работает - не лезь, тем более еще семерка ждет восстановления.
И еще раз спасибо всем за консультации по ремонту, просто кладезь знаний!